Replogle Globes Home View Replogle Globes Products Learn About Globes Where to buy Replogle Globes About Replogle Globes

Please use the links below to update your Replogle Intellipen™, or to download the Intelliglobe™ instructions.

System Requirements
Hardware Required
  • Minimum USB 1.0 or newer
  • USB Mini-B Cable included with Pen Drive
  • Intelliglobe™ Pen
Minimum Operating System Required
  • Windows 2000, Service Pack 4
  • Mac OS X 10.4
  • Any current Linux, Unix, BSD Operating System that supports USB device discovery and web browsing
Software Requirements
  • Adobe Acrobat Reader 5 or newer
  • ZIP utility to decompress Pen Update- Windows XP SP3 and Mac OS X supports ZIP natively, other Operating Systems may require download of ZIP utility such as 7-ZIP at 7-zip.org
Minimum Disk Space prior to update
  • 500 MB in order to update the pen drive
Pen Updates
Instructions
 Intelliglobe
Contact Us / Dealer eStore / Image Library / Scanglobe / Email this Page / Privacy.  ©2014 Replogle Globes. All rights reserved.